A forum for any Z enthusiast! Young or old. This is a place for those who have questions and need help or Z enthusiasts that just wanna hang out and share stories of their Z's
 
HomePortalGalleryFAQSearchMemberlistUsergroupsRegisterLog in

Share | 
 

 transmission

Go down 
AuthorMessage
iscopa



Number of posts : 2
Age : 60
Location : Ottawa Canada
Car Year/Make/Model : 280z 1978
Registration date : 2010-04-19

PostSubject: transmission   Mon Apr 19, 2010 5:06 am

Hi everyone! I own 1978 280z, my problem is when i let up my clutch the car trembles so to fix this ive changed the following with new parts ... Flywheel, clutch, pressureplate, release bearing, transmission with rebulit, and transmission support bushing and guess what its still doing the same... Can anyone give some advice
Back to top Go down
View user profile
jjewell

avatar

Number of posts : 38
Age : 43
Location : bangor pa
Car Year/Make/Model : 87 turbo 03 enthusiast
Registration date : 2008-07-18

PostSubject: Re: transmission   Mon Apr 19, 2010 10:31 am

my guess would be to check the drive shaft and the rear. maybe its doing it when its under load for some reason. you've changed all the things i would have changed first already. i've already swapped the tranny in my z31 just to find out the rear was shot.
Back to top Go down
View user profile
 
transmission
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
Zenthusiast.net :: General Topics :: General Z Discussion-
Jump to: